:: Re: [DNG] We need upgrade reports
Top Page
Delete this message
Reply to this message
Author: Andreas Messer
To: dng
Subject: Re: [DNG] We need upgrade reports
On Tue, Dec 31, 2019 at 02:58:10PM -0500, fsmithred via Dng wrote:
> Please upgrade your highly customized and configured ascii production system
> to beowulf and tell us if it works. Okay, DO THIS ON A COPY, not the real
> thing.

Well, already did on my production systems, not many test machines for home use
:-). I have three machines updated within the last two months, sorry, a
little bit lengthy now:

[notebook]: Updated from ascii to beowulf roughly a month ago. KDE/Plasma
Desktop, Firefox, Visual Code from external Microsoft repo, LVM volumes.
No issues during upgrade (*), system seems to be stable (no crashes so far)

* I don't remind all details anymore but see below for more recent update.

[soho nas/server]: Also about a month ago. This was a new machine with
a minimal ascii as trampoline for installing beowulf. No issues during
upgrade. Machine is headless, no elogind. Currently working services are:
Samba AD DC for Windows clients and providing LDAP/Kerberos to Linux
hosts, NFS fileserver, Lighttpd + PHP FPM, MariaDB, Amanda Client. The
machine sometimes looks up: once a month or so, either during standby (to
ram) or wakeup. I suppose related to Mainboard or Bios.

[workstation]: Upgraded just a few days ago from ascii to beowulf. Also
a pure desktop machine: KDE/Plasma, KMail, Gnome, Firefox, KiCad,
Amanda server (not yet used again), Visual Code, Gimp, LVM for root and
other filesystems, mixed NVME/HDD.

I run upgrade commands from within a "screen" session in a terminal from
KDE. Since I forgot to disable screen-saver before, it locked after a
while and prompted me to switch to text console, login and perform a
"loginctl" command to unlock. This worked, however I'd recommend to
either disable all screen savers during upgrade or use a text console
for upgrade.

I was required some repeats of the "upgrade" / "dist-upgrade" commands.
Also an "--fix-broken install" was needed. I think this was related to
autofs package: I host a local package mirror as NFS share which is
mounted through autofs, when updating autofs, it will restart / remount
all autofs shares so the autofs_*.deb disappeared during install of autofs
which dpkg doesn't seem to like :-)

After upgrade KDE desktop was not installed anymore. I had to manually
install it again (kde-plasma-desktop package). Also elogind* was not
upgraded, I think the later was related to libsystemd0 package, which was still
installed. I had to manually remove libsystemd0. Afterwards I could
upgrade elogind*. Is it correct that libsystemd0 is still present in
deb.devuan.org for beowulf? Since libelogind0 replaces it, it
shouldn't be there at all, right?

After upgrade I noticed, that sound in KDE was not working as expected.
KDE/Plasma seem to have more or less fully switched to pulseaudio. The
pulseaudio package was installed but not working properly. Today I just
figured out, that the libpulse0 package from debian ships with a file


which changes behavior to not automatically start pulseaudio server by
client if needed. Probably since pulseaudio is now started through
systemd on Debian:


This change actually breaks sound/mixers for all pulseaudio using
applications, A freshly installed beowulf with KDE desktop might not
deliver sound out of the box.

As a quick fix I edited


and commented out the setting made there. I see two more persistent

- provide own libpulse0 package without that config file
- create a devuan package which installs a 01-reenable-autospawn.conf file
to revert the setting

Another noticeable thing (Wife) is, that the banshee package is not available
anymore (removed from Debian as well). With some quirks I was able to
generate it locally from the Debian source. We evaluated some
alternatives before but most of them suffer GUI usability and focus to much
on for our mood unecessary features.

KiCad (electronic cad programm) worked fine at once. Old project was
converted without issues and was directly useable again.

gnuPG keyid: 8C2BAF51
fingerprint: 28EE 8438 E688 D992 3661 C753 90B3 BAAA 8C2B AF51