:: Re: [DNG] snetaid debs...
Top Page
Delete this message
Reply to this message
Author: aitor
To: dng
Subject: Re: [DNG] snetaid debs...

On 6/11/21 10:36, al3xu5 via Dng wrote:
> I tried to install the new packages on Beowulf:
> - snetaid 1.0-1 package was installed, but I have:
> $ sudo service snetaid status
> /usr/sbin/snetaid: error while loading shared libraries: libnetaid.so.1:
> cannot open shared object file: No such file or directory
> - indeed when trying to install the libnetaid 1.0-1 I get a dependency
>    error being required libc6>=2.29 ...

I've got the same error in Void Linux due to other reasons. Setting the environmental variable:

|export LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu|

solved the issue, as you can see in the following screenshot:

https://www.gnuinos.org/simple-netaid/simple-netaid_voidlinux.png <https://www.gnuinos.org/simple-netaid/simple-netaid_voidlinux.png>

However, simple-netaid is not working 100% in Void Linux yet, though there is not much left:

- Configure the runit scripts for snetaid in /etc/sv/snetaid.

- Install ifupdown, a runtime dependency.