:: Re: [DNG] When upgrading to Beowulf…
Top Page
Delete this message
Reply to this message
Author: 'smee
To: dng
Subject: Re: [DNG] When upgrading to Beowulf please test and report issues with eudev-3.2.9-2 from unstable!
On Sat, 2020-01-11 at 10:50 +0100, Svante Signell via Dng wrote:
> On Fri, 2020-01-10 at 18:15 -0700, 'smee via Dng wrote:
> > > On Fri, 2020-01-10 at 11:25 +0100, Svante Signell via Dng wrote:
> > I just installed a fresh ascii install, ran update-initramfs -u and
> > had
> > no errors (I did see the same last line that's mentioned). So I
> > tried
> > apt remover *nonfree, let that run, and tried again and it produces
> > that set of errors when the nonfree firmware is not there.
> Good!
> > So, as you mentioned the errors happened after the upgrade to
> > Beowulf.
> > I'm going to assume that it was just because firmware-misc-nonfree
> > was
> > in a bad state after the upgrade and that a reinstall of both
> > firmware-
> > misc-nonfree and firmware-linux-nonfree would fix the issue there.
> > I
> > can test that if you'd like, by doing the reinstall and running
> > update-
> > initramfs -u again.
> Yes, please do. Then we know if we can close this issue or not.

After reinstalling firmware-misc-nonfree and firmware-linux-nonfree,
there is now only one error below about some missing nvidia firmware.

update-initramfs: Generating /boot/initrd.img-4.19.0-6-amd64
W: Possible missing firmware
/lib/firmware/nvidia/gv100/acr/ucode_load.bin for module nouveau
live-boot: core filesystems devices utils udev blockdev dns.

> Note that you
> can choose how to update and backup by editing: /etc/initramfs-
> tools/update-
> initramfs.conf. You also have a lot of options for updating, see the
> manpage for
> update-initramfs.
> If possible, do also try to find out if your new (beowulf) kernel
> initrd(.img-
> 4.19.0-6-amd64, or whatever) has firmware-*-nonfree or not. (Don't
> know how
> yet).

I ran update-initramfs -uv to get some verbose output. Unfortunately it
spit out about 1500 lines, which is pasted here.


The verbose output does seem to include a bunch of nonfree modules,
including AMD, intel NVIDIA, so I think this is definitive evidence
that the initramfs image should include the nonfree. The only thing is
that one entry that I'm still getting.