:: Re: [DNG] When upgrading to Beowulf…
Top Page
Delete this message
Reply to this message
Author: Svante Signell
To: dng
Subject: Re: [DNG] When upgrading to Beowulf please test and report issues with eudev-3.2.9-2 from unstable!
On Fri, 2020-01-10 at 18:15 -0700, 'smee via Dng wrote:
> > On Fri, 2020-01-10 at 11:25 +0100, Svante Signell via Dng wrote:
> > >
> I just installed a fresh ascii install, ran update-initramfs -u and had
> no errors (I did see the same last line that's mentioned). So I tried
> apt remover *nonfree, let that run, and tried again and it produces
> that set of errors when the nonfree firmware is not there.


> So, as you mentioned the errors happened after the upgrade to Beowulf.
> I'm going to assume that it was just because firmware-misc-nonfree was
> in a bad state after the upgrade and that a reinstall of both firmware-
> misc-nonfree and firmware-linux-nonfree would fix the issue there. I
> can test that if you'd like, by doing the reinstall and running update-
> initramfs -u again.

Yes, please do. Then we know if we can close this issue or not. Note that you
can choose how to update and backup by editing: /etc/initramfs-tools/update-
initramfs.conf. You also have a lot of options for updating, see the manpage for

If possible, do also try to find out if your new (beowulf) kernel initrd(.img-
4.19.0-6-amd64, or whatever) has firmware-*-nonfree or not. (Don't know how