:: Re: [DNG] When upgrading to Beowulf…
Top Page
Delete this message
Reply to this message
Author: 'smee
To: dng
Subject: Re: [DNG] When upgrading to Beowulf please test and report issues with eudev-3.2.9-2 from unstable!

> On Fri, 2020-01-10 at 11:25 +0100, Svante Signell via Dng wrote:
> > On Thu, 2020-01-09 at 16:17 -0700, 'smee via Dng wrote:
> > > Actually, after apt remove *nonfree (and a reboot for good
> > > measure),
> > > update-initramfs -u still comes back with the same exact output
> > > including that last line...
> >
> > I think your problems are with the new (beowulf) image. It is not
> > using any non-
> > free parts (or does it?). Did you boot with the old (ascii) kernel
> > and tried
> > update-initramfs -u?
> >
> > On my images I only have firmware-linux-free installed, dpkg -l |
> > grep firmware.
> >

> I just ran update-initramfs -u on my ascii install (on which I also
> removed *nonfree yesterday) and I'm still getting the same message.
> IIRC, I ran the same command yesterday before ever removing anything
> and was seeing the same results.
> I can double-check that later today by installing ascii fresh and
> seewhat I get.

I just installed a fresh ascii install, ran update-initramfs -u and had
no errors (I did see the same last line that's mentioned). So I tried
apt remover *nonfree, let that run, and tried again and it produces
that set of errors when the nonfree firmware is not there.

So, as you mentioned the errors happened after the upgrade to Beowulf.
I'm going to assume that it was just because firmware-misc-nonfree was
in a bad state after the upgrade and that a reinstall of both firmware-
misc-nonfree and firmware-linux-nonfree would fix the issue there. I
can test that if you'd like, by doing the reinstall and running update-
initramfs -u again.

> > _______________________________________________
> > Dng mailing list
> > Dng@???
> > https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng