:: [DNG] Anatomy of a footgun (was: Wa…
Top Page
Delete this message
Reply to this message
Author: Joel Roth
To: dng
Old-Topics: Re: [DNG] OT: Wanted: small linux iso with rsync
Subject: [DNG] Anatomy of a footgun (was: Wanted: small linux iso with rsync
On Wed, Mar 22, 2023, Steve Litt wrote:
> Joel Roth via Dng said on Tue, 21 Mar 2023 22:01:59 -1000
> >Hi list,
> >
> >Subject line says it all. I'd like a live iso of a small
> >utility distribution like dsl. It must be a fairly recent
> >kernel and have rsync.
> Hi Joel,
> Great to talk to you again. I still remember the Modular Debian email
> list: Thanks for that.
> My goto distro for backup, transfer and troubleshooting is System
> Rescue CD. It has rsync:
> https://www.system-rescue.org/manual/Backup_and_transfer_your_data_using_rsync/
> It inits with systemd but I don't care, because it's an appliance, and
> I never DIY my appliances.
> IIRC System Rescue CD has a nice RAM tester you booot into, Gparted,
> ddrescue, blkid, lsblock, and a whole bunch of other stuff you need to
> rescue data or bootability. See
> https://www.system-rescue.org/System-tools/ for its tools.
> It has LVM tools if you drive on that side of the street. System Rescue
> CD can be installed on a thumb drive, and I think also on a DVD, which
> I personally prefer, always assuming it works (with UEFI you never know
> what will and won't boot).

Thanks, Steve

I got the partition to boot partially using SuperGrub2.
Later solved the rest of the puzzle.

Now I realize that by using rsync to naively backup one machine to
another, I

* clobbered /etc/fstab, with root set to a non-existing UUID.
This led to a "can't find stage1 error" with grub, a read-only
root filesystem that was clean and yet couldn't be
remounted rw.

Should have used apt-get upgrade for the system,
and rsync for /home/only.

* clobbered lilo, the bootloader, boot fails - oops!

* garbled the permissions of /tmp - X won't start

* rsync/pebcak somehow missed copying over a directory /usr/share/X11/xkb
that also broke X.

With the system being broken, I tried several utility distros
to get on my feet.

SuperGrub2 is just awesome, 16MB of grub plus pixie dust
autodetects kernels and constructs a boot menu.

Rescatux seemed promising with an menu of choices to diagnose
and fix problems, but didn't notice the glaring issue of non-existing UUID
in fstab. (note to self: file bug report).

Knoppix has grub utilities, but not lilo.

Bootable rEFInd didn't find anything, probably because I
wasn't using EFI. Otherwise I've had good experiences with

SystemRescue seems good, with a FindBoot option on the menu.

The bad fstab upset grub-install: not able to find stage1.

So at the top of the list what to check, yet still took time
to see the light.

By writing here, perhaps I'll remember next time.


Joel Roth