:: [DNG] Solved: legacy boot Chimaera…
Top Page
Delete this message
Reply to this message
Author: Fred
To: dng
Subject: [DNG] Solved: legacy boot Chimaera?
On 1/4/23 14:34, Ralph Ronnquist wrote:
> On Wed, Jan 04, 2023 at 01:41:54PM -0700, Fred wrote:
>>>>>> Device     Boot Start    End Sectors  Size Id Type
>>>>>> /dev/sdb1  *        0 761855  761856  372M  0 Empty
>>>>>> /dev/sdb2        4040   5511    1472  736K ef EFI (FAT-12/16/32)

>>>> On this computer usb automounts when plugged in.
>>> We're not really talking about auto-mounting - we're talking about finding a
>>> bootable device.
>>>> I dd'ed the .iso to /dev/sdb which maybe is not correct?
>>> No, that is correct.
>>>> /sbin/fdisk -l shows the stick now has sdb1 and sdb2. The automount
>>>> picks sdb2.
>>> That seems bizaree, when booting from USB, since it is the first partition
>>> which has the boot flag set (see above).
>>>> So we are back to square 1. The usb stick should be a valid boot device
>>>> and the mini-pc doesn't like what it sees there. It does see the stick
>>>> because the led comes on and at times it blinks rapidly.
>>> Try downloading the image and then using fdisk to change the first partition
>>> type to FAT32, then see which partitiong the machine tries to boot from.
>>> Antony.
>> I can report some progress! Another poster sent me some links off-list.
>> One was to a youtube video that is to solve the same problem. It turns out
>> there is another boot option menu accessed by F9 that tells it which of the
>> available options to actually boot from. The HP manuals don't mention F9.
>> F9 let me select the usb stick and then the Devuan installer came up.
>> I was able to configure the network and partition the hd without any problem
>> but the install stopped at installing the base system. The error is:
>> Debootstrap Error: Failed to determine the codename for the release.
>> I am using the netinstall .iso.
>> Help!
>> Best regards,
>> Fred
> I'm not sure what happens to my replies, but let me try again.
> The iso is a so called "hybrid boot" iso that boots with legacy
> BIOS as a CD, with legacy BIOS as a bootable partition, and with UEFI
> BIOS through an EFI partition.
> To that end, its MBR includes both a DOS and a GPT partition table,
> and it first partition is an iso9660 filesystem spanning the whole
> media including an El Torito boot image that springs into effect when
> booting as CD, while its second partition spans an EFI image file
> within the iso9660 filesystem. The MBR also has the "isolinux" initial
> 440 bytes for a harddisk boot into partition 0.
> I think you should choose the CD boot option because I think your BIOS
> has detected the USB as a CD image when scanning for CD images, and
> then it has deteced the partition table when scanning for those.
> Obviously, if you have tried this and it fails, then I'm wrong.
> Which ISO do you use?
> regards,
> Ralph.
> _______________________________________________
> Dng mailing list
> Dng@???
> https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng

Hi Ralph,

Your earlier posting did show up.

I have since found that in addition to the bios listing for boot device
which does include USB there is a second menu, accessed by F9, which
tells to computer which of the available devices to actually, like now,
boot from. USB is included and the Devuan installer came up right away.
So that problem is solved. Maybe I should start a new thread for the
present problem and mark this one solved.

Best regards,