:: [DNG] Network configuration (was Re…
Top Page
Delete this message
Reply to this message
Author: Olaf Meeuwissen
To: Didier Kryn
CC: dng
Old-Topics: Re: [DNG] Danger: Debian POSIX hostility
Subject: [DNG] Network configuration (was Re: Danger: Debian POSIX hostility)
Hi Didier,

Didier Kryn writes:

> Le 17/09/2020 à 13:34, Olaf Meeuwissen via Dng a écrit:
>> apt purge network-manager
>> solved it for me ;-)
>> Eh, perhaps I should mention that I also did a
>> apt install netplug wpasupplicant ifupdown
>> and tinkered a bit to get my interfaces(5) and wpa_supplicant.conf(5)
>> snippets in working order.
> That's what I used to do for the last 10 years, except ifplugd
> instead of netplug.

You are aware of ifplugd (and libdaemon0 on which it depends) originate,
right? I guess I just had a knee-jerk reaction to that, similar to the
way people on this list have something against pulseaudio :-)

$ apt-cache show ifplugd libdaemon0 | grep Homepage:
Homepage: http://0pointer.de/lennart/projects/ifplugd/
Homepage: http://0pointer.de/lennart/projects/libdaemon/

Anyway, if ifplugd works for you that's fine. For me, netplug does the
job and didn't need any configuration. It worked out of the box.

> It works perfectly with some hand tweaking of /etc/interfaces.
> Also you need to configure /etc/wpa_supplicant/wpa_supplicant.conf
> by hand or install wpa_gui.

I used wpa_gui on one occasion and rolled a wpa_supplicant.conf for
roaming purposes by hand following the manual page and examples. Not
exactly user friendly but not rocket science either.

> Anyway, wpa_supplicant.conf needs the following instructions:
> ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=dialout
> update_config=1
> You can choose a different group, and you should make yourself a
> member of this group.

I'm not using the GROUP variable on my home laptop (nor do I have the
`DIR=` bit in there). I am member of the netdev and plugdev groups. I
believe that takes care of things for me.

I also don't have update_config set in my /etc/wpa_supplicant/conf.d/
# Eh, yes, I don't have a wpa_supplicant.conf file. I wrote snippets
# for each of the places where I need things to work.

At the office I use a wpa-roam.conf. See the example file for more info
on setting this up.

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join