:: Re: [DNG] terminal paste failure
Top Page
Delete this message
Reply to this message
Author: Hendrik Boom
To: dng
Subject: Re: [DNG] terminal paste failure
On Wed, Jul 01, 2020 at 05:36:05PM -0400, Haines Brown wrote:
> Last night for some reason I can no lonter paste text selected in
> nano to another nano document with the middle mouse button. It seems
> to have failed in the course of the night.
> I've been running Beowulf ever since the beta. I don't have a desktop
> environment but rely on fluxbox for window management.
> The problem affects both root and user. It does not affect selecting
> and pasting between GUI applications such aa emacs. It affects both
> eterm and mlterm. eTerm puzzles me. I installed xterm, but it runs
> eterm.
> Clearing the caches did not help:
> $ xsel -cp && xsel -cs && xsel -cb
> Selected text shows up in xcliboard, and so the problem seems to be
> with pasting.
> I tried Ctl-Shift-c and Ctl-Shift-v without luck.
> I tried Ctl-w to cut a work, but Ctl-y did not paste it.
> I repladed the (wireless) mouse and used it in a different port.
> Reconfiguring xserver-xorg and rebooting did not help.
> However, an old wired USB mouse does not suffer from the problem.

I had similar problems a few days ago. Suddenly some cut-and-pastes
didn't work. In particular, I was unable to cut from emacs or a
terminal (I forget which teminal program; it could have been
qterminal, xterm, or uxterm) and paste in the URL bar of firefox. It
didn't matter whether I used the outline in emacs and paste with
middle-click or the edit manu in emacs and the paste menu item on

I wondered whether this might be because of the two somewhat
incompatible mechanisms in X versus in a desktop. Sometimes this means
one kind of cut doesn't match another kind of paste and I just try again
with a different combination. But this time switching kinds didn't

And some pieces of software try hard to be compatible with both. It can
help, but what to do if the two paste buffers have different
information? Or maybe I'm off-track here and have some
misunderstanding about how the cu/paste mechanisms ineract.
There does seem to be some conflict between X and desktops, though.

I was baffled. I wrote a note about it to this mailing list and got no
reply. I couldn't remember doing any upgrades or other system changes

But after I logged out and logged in again (I forget whether I also
turned the machine off and on again; I think I didn't), everything was

I too use a wireless mouse.

I still do not understand what happened.

-- hendrik

> Haines Brown