:: Re: [maemo-leste] alsactl trouble w…
Top Page
Delete this message
Reply to this message
Author: Pavel Machek
To: Merlijn Wajer
CC: maemo-leste, mpartap, sre, martin_rysavy, nekit1000, Tony Lindgren
Subject: Re: [maemo-leste] alsactl trouble was Re: Grand plan to get make phones... phone (for Motorola Droid 4)

> >>> user@devuan-droid4:/tmp$ sudo alsactl store Audio delme.foo
> >>> ALSA lib conf.c:1887:(_snd_config_load_with_include)
> >>> _toplevel_:160:10:Unexpected char
> >>> user@devuan-droid4:/tmp$
> >>> user@devuan-droid4:/my/unicsy_demo$ cat /proc/asound/cards
> >>>  0 [Audio          ]: Droid_4_Audio - Droid 4 Audio
> >>>                        Droid 4 Audio

> >>
> >> No idea yet, but will take a look today. Definitely would explain why
> >> the audio start is also never stored / loaded upon boot.
> >
> > For the record, these are solved. There are multiple "audio cards" on
> > leste, so command line needs to be tweaked. Oh and that "#" character
> > really breaks alsactl, but it is easy to just remove that by hand.
> Sorry, what is solved, and how?

> I don't think it's solved in current Leste images - so what should be
> done, apart from removing the '#' characters?

I don't believe there's bug in current Leste images -- apart from that
'#' character.

It simply requires name of the audio card, and I updated Ofone to do
the right thing.

I was doing "sudo alsactl restore -f delme.foo". And that works on my
hacked system but not on Leste. There, "sudo alsactl restore Audio -f
delme.foo" is required. (Audio is name of the soundcard, AFAICT).

> PS: Got icd2 plugin + UI for data connection the droid4 to work over the
> weekend - will try to have something usable soon:
> https://wizzup.org/droid4-cellular-0.1.png

Congratulations! :-).

Best regards,

(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html