:: [DNG] Kernel modules not found duri…
Top Page
Delete this message
Reply to this message
Author: Olaf Meeuwissen
To: dng
Subject: [DNG] Kernel modules not found during Beowulf install

# Full well aware that this is still experimental but ...

I just tried installing from the netboot/gtk/mini.iso downloaded from


but ran into the following warning on the Download installer components

No kernel modules were found. This probably is due to a mismatch
between the kernel used by this version of the installer and the
kernel version available in the archive.

This happens on, at least, the 20190207+devuan1 and 20190216+devuan1
versions the netboot/gtk/mini.iso image. I have tried the following
Devuan archive mirrors:

- jp.deb.devuan.org
- pkgmaster.devuan.org
- deb.devuan.org

but the symptoms do not change.

Continuing without loading kernel modules leads to a situation where my
machine's hard disk is not listed as a possible partition target :-/

# RAID and LVM partitioning options are not availabe either.

The installer uses a 4.19.0-2-amd64 kernel version from a 4.19.16-1
release (2019-01-17). It looks like a newer version, 4.19.28-2, has hit
the Debian buster archives[1] (2019-03-27) providing a 4.19.0-4-amd64
kernel ... leaving our installer without any kernel modules because
there is no 4.19.0-2-amd64 kernel image package in the Debian repos
anymore :-(

[1]: https://tracker.debian.org/news/1036492/linux-41928-2-migrated-to-testing/

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join