:: Re: [DNG] logging uses of machine-i…
Top Page
Delete this message
Reply to this message
Author: KatolaZ
To: dng
Subject: Re: [DNG] logging uses of machine-id
On Tue, Mar 12, 2019 at 04:24:43PM +0100, Jaromil wrote:
> dear Didier,
> thanks for this quick C monitoring tool using the inotify API
> I think this may be useful also for /etc/machine-id - which may be a
> different ID from dbus I believe?
> meanwhile an update on my adventures using chromium on Beowulf: it
> basically stopped working since I overwrote my machine-id with
> "d34dc0d3d34dc0d3d34dc0d3d34dc0d3" because, I believe, is not the
> machine-id that chromium registered for the sessions of my profile /
> users logged into Google.

Sorry Jaromil, but I can't reproduce this. I am running beowulf. I had
no /etc/machine-id. I installed the Chromium package through
apt-get. It complained that I needed to install chromium-sandbox as
well, and I did. I launched it from a terminal and it "worked" (no
machine-id so far).

Then I closed it, created a /etc/machine-id with:

# head -c 4 /dev/random | md5sum | cut -d " " -f 1 > /etc/machine-id

and restarted it. It worked. Then I changed the machine-id and
restarted it several time, and it worked. Then I put /etc/machine-id
equal to your "d34dc0d3d34dc0d3d34dc0d3d34dc0d3" and it worked. Then I
removed /etc/machine-id again, and chromium still works. Then I also
stopped dbus and removed /var/lib/dbus/machine-id, so no
/etc/machine-id, no /var/lib/dbus/machine-id, and no dbus
running. Close and open again, and it works.

Then I uninstalled chromium because it sucks anyway.

We shall probably dig a deeper into this...



[ ~.,_  Enzo Nicosia aka KatolaZ - Devuan -- Freaknet Medialab  ]  
[     "+.  katolaz [at] freaknet.org --- katolaz [at] yahoo.it  ]
[       @)   http://kalos.mine.nu ---  Devuan GNU + Linux User  ]
[     @@)  http://maths.qmul.ac.uk/~vnicosia --  GPG: 0B5F062F  ] 
[ (@@@)  Twitter: @KatolaZ - skype: katolaz -- github: KatolaZ  ]