:: [DNG] window manager fails to conne…
Top Page
Delete this message
Reply to this message
Author: Haines Brown
To: dng
Subject: [DNG] window manager fails to connect to XServer
I mistakenly copied all files in my home directory to another
directory. When I restored the files from that directory, $ startx was
no longer able to start the window manager. I run Devuan Daedalus
with Fluxbox window manager but with no desktop environment.

$ echo $DISPLAY

The /etc/xorg.conf.d directory is empty, which I take to be normal

When I try to start fluxbox as either user or root I get:

$ fluxbox
Error: Couldn't connect to XServer passing null display

I tried to reboot and to restall fluxbox.

Flubox is present and is the default:

  $ sudo update-alternatives --config x-window-manager
    Selection    Path                   Priority   Status
  * 0            /usr/bin/startfluxbox   50        auto mode
    1            /usr/bin/startfluxbox   50        manual mode

$ wmcrtl -m
Name: Fluxbox
Class: N/A
Window manager's "showing the desktop" mode: N/A

I had commented my ~/.Xauthority file that has cookies for display
password becasue I did not need it. Uncommenting it now did not help.

The /etc/X11/xinit/xinitrc file has . /etc/X11/Xsession . This is normal

The fluxbox command itself seems OK

$ ls -la | /etc/X11 | grep fluxbox
drwxr-xr-x 2 root root 4096 Mar 18 06:10 fluxbox

I look at .xsession-errors. I expected but did not find .fluxbox calls.
There were failures to set values and a reversion to defaults. For

Failed to read: session.ignoreBorder
Setting default value

I give all clients access to XServer

$ sudo xhost +
access control disabled, clients can connect from any host

This worked only when done by root, not by user.

\usr\bin\startx calls ~/.xinitrc and it has line exec startfluxbox.
The problem seems to be that the XServer cannot see any fluxbox


     Haines Brown