:: Re: [DNG] Problems in a Daedalus fr…
Top Page
Delete this message
Reply to this message
Author: Olaf Meeuwissen
To: Alexandros Prekates
CC: dng
Subject: Re: [DNG] Problems in a Daedalus fresh installation with tasksel -> console productivity

Alexandros Prekates via Dng <dng@???> writes:

> System:         PC (amd64)
> Distro:         Devuan 5 (Daedalus)
> Installation media:     netinstall iso for amd64
> Installation choices:     Configure the package manager / Software
> selection (Tasksel) / Console Productivity ssh and web server
> Installation Tag:         Desktopless,console productivity
> installation. Postinstallation main packages:     xorg,awesome I
> desribe the issues:

> [...]
> --- isc-dhcp-clientpolluting syslog with the same message
> continuously
> Repeatedly the same message is added: dhclient[2336]: Failed to get
> interface index: No such device (with another 10 lines of
> suggestions) I corrected that by installing udcpcd

This rang a bell. I saw the same or something very similar a while back
on the one machine where I still install recommended packages. I only
noticed it after quite a while when I ran an `ls -l` on /var/log and saw
a rather bloated syslog.

I traced it down to runit-services using eth1 by default (or hard-coded,
don't remember) and blindly assuming ifconfig is installed. The package
didn't seem to be doing anything that was useful for me so I purged it.
Problem solved, for me, and I'm still using isc-dhcp-client.

Hope this helps,
Olaf Meeuwissen