:: [devuan-dev] Obsolete dependency - …
Top Page
Delete this message
Reply to this message
Author: Rob Pearce
To: Devuan Dev Team
Subject: [devuan-dev] Obsolete dependency - lsb-base
Hi folks,

I'm working on updating the Devuan "slim" package for the newly released
V1.4.0 upstream. When I ran lintian on it, I got an error about
depending on an obsolete package, namely "lsb-base (>= 3.0-6)"

A bit of Googling suggests the lsb-base package was removed from Debian
some years back, and that its last incarnation contained just one "real"
file - /lib/lsb/init-functions. This is referenced by debian/slim.init,
which I believe is the init script for use with SysVInit. That would tie
in with the current provider of init-functions being sysvinit-utils.

I think, therefore, that it's probably safe to remove the offending
entry in the depends list. The question is whether I need to replace it
with anything. My instinct is that I don't, since the only requirement
of that file is when using an init system that guarantees to provide it.
However, I see from the changelog that the dependency was added at
1.3.6-5.1+devuan6 (by Mark Hindley) so I'd appreciate any opinions on
the matter.



Maintainer of the <href="https://sourceforge.net/projects/slim-fork/">SLiM Login Manager fork</a>