:: Re: [DNG] simple-netaid built from …
Top Page
Delete this message
Reply to this message
Author: aitor
To: dng
Subject: Re: [DNG] simple-netaid built from source (was: simple-netaid for daedalus)
Hi Joel,

On 19/12/22 10:03, Joel Roth via Dng wrote:
> After rebooting, ubus and snetaid daemons are present. and
> the vte application works as expected. It can associate
> with an ssid and request an ip address. It even recognizes
> saved entries from the previous simple-netaid. I'm a happy camper.
> The command line app still segfaults on my system.

I've done a lot of improvements and fixed some bugs. Deb packages are available for chimaera only, but all the sources in git are up-to-date.
The new version of simple-netaid-cdk is now reactive to netlink events caused by foreign processes.

Are you still getting the same segfault in the command line?

I tried running several instances of simple-netaid-cdk at the same time, within the vte container on the one hand, and the command line app on the other,
and everything worked fine. Note that the command line app must be shutdown from the ncurses menu, not from the frame of the terminal emulator,
and this is the raison d'être of a custom Vte container.

One clarification: I think that ifupdown is missing in chimaera because it has been replaced with ifupdown2, which I'm not familiar with.
Simple-netaid works only with ifupdown so far (available in the gnuinos repo). The latter is written in python.

On the other hand, all the iso images of gnuinos chimaera have been updated as well. Xfce4 ships with xfce4-hopman-plugin in the panel.