:: Re: [DNG] legacy boot Chimaera?
Top Page
Delete this message
Reply to this message
Author: Fred
To: dng
Subject: Re: [DNG] legacy boot Chimaera?
On 1/4/23 07:17, Fred wrote:
> On 1/4/23 01:19, Antonio Rendina via Dng wrote:
>> You may need to disable fast boot as well and use legacy boot (if you
>> didn't do it so far).
>> Looks to me that it didn't recognize the USB key as a boot key, or it
>> tried to boot from hard drive without checking the usb key. Try the
>> usb key on another computer, just to be sure that the key is working
>> well.
>> Regards,
>> Antonio
> Fast boot was disabled by default.
> I agree completely with your observation.
> I am willing to try the usb stick on another computer but how do I exit
> the installer if it comes up without changing anything on the computer?
> I mounted a CD I used to install Beowulf on another computer and found
> it had lots of files including one called boot versus the two .efi files
> I found on the usb stick.
> I am going to try again using the netinstall iso.
> Best regards,
> Fred
>> Il 04/01/23 02:38, Fred ha scritto:
>>> On 1/3/23 18:22, john faulk wrote:
>>>> Have you tried going into the bios at all?
>>> Yes, I have been all through the bios.  I checked the boot order
>>> which is:
>>> CD (which the pc doesn't have)
>>> USB
>>> Network  (which I removed)
>>> There is another page that also lists the internal hard drive.
>>> The boot options are: Legacy and Secure Boot which appears to be a
>>> Windows thing.  There is a tab for UEFI drivers.  If that is selected
>>> it changes to a page that says I will be directed to a page for a
>>> third party rom also accessible  with F3.  If that is selected it
>>> changes to a page with only the option: EXIT which reboots the pc.  I
>>> assume the rom is not installed.
>>> Best regards,
>>> Fred
>>>> On Tue, Jan 3, 2023, 7:18 PM Fred <fred@???
>>>> <mailto:fred@blakemfg.com>> wrote:
>>>>     On 1/3/23 15:54, Antony Stone wrote:
>>>>      > On Tuesday 03 January 2023 at 22:28:41, Fred wrote:
>>>>      >
>>>>      >> Hello,
>>>>      >>
>>>>      >> I bought a "refurbished" HP EliteDesk 800 G2 mini-pc with the
>>>>     intention
>>>>      >> of running Chimaera on it.  However, it will only legacy boot
>>>>     and the
>>>>      >> .iso install files for Chimaera on the USB stick are .efi.  Is
>>>>     all hope
>>>>      >> lost or is there a work around?
>>>>      >
>>>>      > Sorry, but I don't understand the problem.
>>>>      >
>>>>      > I have at least four machines here which have no concept of UEFI
>>>>     - they boot
>>>>      > using BIOS only, and yet they (start and) run Chimaera quite
>>>> happily.
>>>>      >
>>>>      > So, when you attempt to install Chimaera on this EliteDesk
>>>>     machine, what
>>>>      > exactly is the problem you run into?
>>>>      >
>>>>      >
>>>>      > Antony.
>>>>      >
>>>>     The pc sees the usb stick as it turns on the led and at times
>>>> makes it
>>>>     flash.  However, what it does is snoop around the local network
>>>>     until it
>>>>     finds the gateway then it downloads Windows 10 and starts setup for
>>>>     that.  If I don't have the Ethernet cable attached it eventually
>>>> brings
>>>>     up a screen with several remote servers and allows one to be
>>>> selected
>>>>     but it won't continue without the network.
>>>>     I used dd to write this file:
>>>>     devuan_chimaera_4.0.0_amd64_server.iso
>>>>     to the usb stick.  I can mount it and see the files:
>>>>     There is: /efi/boot/bootia32.efi
>>>>     and:      /efi/boot/bootx64.efi
>>>>     What can I check now?
>>>>     Best regards,
>>>>     Fred
>>>>     _______________________________________________
>>>>     Dng mailing list
>>>>     Dng@??? <mailto:Dng@lists.dyne.org>
>>>>     https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng
>>>>     <https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng>

I downloaded the netinstall iso and put it on the usb stick. I mounted
the stick and found it has the same type of files as before.

Device     Boot Start    End Sectors  Size Id Type
/dev/sdb1  *        0 761855  761856  372M  0 Empty
/dev/sdb2        4040   5511    1472  736K ef EFI (FAT-12/16/32)

These are on /dev/sdb2

It appears the iso files do not now legacy boot. Maybe I have to
install an early version of Devuan and upgrade. But would the boot
method stay legacy with the upgrade?
Best regards,