:: [devuan-dev] bug#722: marked as don…
Top Page
Delete this message
Reply to this message
Author: Devuan bug Tracking System
To: Mark Hindley
Subject: [devuan-dev] bug#722: marked as done (poppler-utils unistallabe - libpoppler102 version conflict)
Your message dated Fri, 4 Nov 2022 21:21:27 +0000
with message-id <Y2WCV9lhIBifmk+5@???>
and subject line Re: bug#722: poppler-utils unistallabe - libpoppler102 version conflict
has caused the Devuan bug report #722,
regarding poppler-utils unistallabe - libpoppler102 version conflict
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@???

722: https://bugs.devuan.org/cgi/bugreport.cgi?bug=722
Devuan Bug Tracking System
Contact owner@??? with problems
Package: poppler-utils
Version: stable 20.09.0-3.1 amd64

To: submit@???
From: amc252@???
Subject: poppler-utils conflict

On Chimaera Linux 5.10.0-18-amd64 Debian 5.10.140-1 (after update and upgrade) when trying to install poppler-utils-20.09.0-3.1 I get the following error message:

$ sudoapt install poppler-utils
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
poppler-utils : Depends: libpoppler102 (= 20.09.0-3.1) but 20.09.0-3.1+deb11u1 is to be installed
E: Unable to correct problems, you have held broken packages.

tried apt --fix-broken but the coflict seems to be with incompatible versions in the repository.


amc252 <amc252@@gmail.com>

amc252 <amc252@@gmail.com>

On Fri, Nov 04, 2022 at 11:01:35AM -0700, amc252 wrote:
> Hi Mark, thanks for your answer.
> chimaera securtiy is not enabled.

Even though not now, it appears to have been in the past.

> $ apt policy poppler-utils libpoppler102
> poppler-utils:
>   Installed: (none)
>   Candidate: 20.09.0-3.1
>   Version table:
>      20.09.0-3.1 500
>         500 http://deb.devuan.org/merged chimaera/main amd64 Packages
> libpoppler102:
>   Installed: 20.09.0-3.1+deb11u1

.. hence this is already installed. That version was uploaded to stable security
on 2022-09-11[1]

But the matching poppler-utils is unavailable now chimaera-security has been disabled

Your options are to

- re-enable chimaera-security
- Use apt-get(1) --allow-downgrades option
- Specify another solution to apt on the command line.



[1] https://tracker.debian.org/news/1361541/accepted-poppler-20090-31deb11u1-source-into-proposed-updates-stable-new-proposed-updates/