:: Re: [DNG] Unable to access pool in …
Top Page
Delete this message
Reply to this message
Author: Ludovic Bellière
To: dng
Subject: Re: [DNG] Unable to access pool in repository
Cc: t
--text follows this line--

On Sat, 16 Jul 2022, Hendrik Boom wrote:

>On Sat, Jul 16, 2022 at 11:11:04PM +1000, onefang wrote:
>> On 2022-07-16 08:21:13, Hendrik Boom wrote:
>> > I tried installing sharutils using aptitude, and was unable to.
>> > aptitude told me:
>> >     Temporary failure resolving 'deb.devuan.org'
>> > and later:
>> >     E: Failed to fetch
>> >        http://deb.devuan.org/merged/pool/DEBIAN/main/s/sharutils/sharutils_4.15.2
>> >        -5_amd64.deb: Temporary failure resolving 'deb.devuan.org'

>> >
>> > In the browser, I had no problem at all reaching http://deb.devuan.org
>> > but http://deb.devuan.org/merged/ did not contain pool:
>> >
>> > Index of /merged
>> >
>> > Name                    Last modified      Size
>> > Parent Directory                             -
>> > dists/                  2022-05-14 11:06    -

>> >
>> > What gives?
>> Your first problem might just be whatever name server you use, it might
>> have been having problems when you tried aptitude, but not when you tried
>> a browser. I recently switched to using unbound for the first time, and
>> I get that several times a day now.
>> deb.devuan.org is a DNS round robin, it'll hand out a different IP from
>> our collection of package mirrors. So the first thing you should do when
>> telling us about problems with it is which IP you got out of it at the
>> time.
>Unfortunately, neither aptitude nor firefox told me the IP number they
> were using.
>Maybe it would be useful if aptitude would do that on this kind of error.
>-- hendrik

A temporary failure resolving a domain name means that you didn't
*resolve* it to an IP address. That means your DNS server cannot either
be reached or is in error. If the remote server cannot be reached,
because it's down, then it'll tell you so.

So the problem here is between you and your DNS, not between you and
Devuan's round robin. Without more information, I can only speculate.

Could be hardware related, a full routing table, your ISP being evil.
Who knows? When that happens, quickly troubleshoot with:

         dig deb.devuan.org


         host deb.devuan.org

dig will tell you which DNS server you default to.