:: [DNG] Unexpected behavior in Python…
Top Page
Delete this message
Reply to this message
Author: Marc Shapiro
To: dng
Subject: [DNG] Unexpected behavior in Python 3 and QT Designer program
I have a program written in Python 3 that uses a .ui file from QT
Designer.  This is the exact same program and .ui file as I used in
Debian.  (It is in /usr/local/bin, which I mount in both places.)  It
retrieves stock data for up to 30 ticker symbols and runs the data
through various calculations before displaying the results in a separate
set of fields for each symbol.

When I run this under Debian Stretch, as each symbol is processed the
results are displayed for that ticker, until I reach the end of the list.

When I run it under Devuan Beowulf, no results are displayed until it is
done with all of the tickers and then all the fields are filled in and
displayed at one.

Have there been changes in the way python and QT Designer interact? 
Under Stretch, /usr/bin/python3 points to python3.5, in Beowulf, it
points to python3.7.  Could this be causing the different behavior.  I
can't just change the link, because I get an error loading the QT module
when I link to python3.5.