:: Re: [DNG] Xorg stopped working afte…
Top Page
Delete this message
Reply to this message
Author: Marc Shapiro
To: dng
Subject: Re: [DNG] Xorg stopped working after upgrade to Beowulf
I do use startx from a terminal login, so this sounds like it could be
the problem.  I'll check it out when I get home, tonight and pass the
results to the list.



On 9/21/20 11:16 PM, wirelessduck--- via Dng wrote:
>> On 22 Sep 2020, at 12:36, Marc Shapiro via Dng <dng@???>
>> wrote:
>> I have pretty much decided that there is no way to upgrade my Debian
>> system to Buster and keep it usable without systemd.  Since I am set
>> up for multiboot, including Devuan Ascii, I decided to upgrade that
>> to Beowulf and see if that will work for me and the others using this
>> box.
>> After upgrading (following the instructions for upgrading an existing
>> Devuan system), I rebooted the computer.
>> First, I booted into my Debian Stretch partition to make sure that
>> everything was still good, there.  Boot, login, start Xorg. All looks
>> good.
>> Logout and reboot into Beowulf.
>> Boot and login went fine.  Starting Xorg, not so well. Tried all
>> three users with no luck.  This worked before the upgrade.  Tried as
>> root.  Success!  So root can start Xorg, but not an ordinary user. 
>> Any ideas what might be wrong. It looks like a permissions issue, but
>> I don't know enough about how X actually starts up to know where to
>> look. Anything that you want me to post to help debug this?
>> Any help appreciated.
>> Marc
> If you are starting X from a terminal/tty, the Beowulf release notes
> mention the required configuration to start X as non-root.
> https://files.devuan.org/devuan_beowulf/Release_notes.txt
> <https://files.devuan.org/devuan_beowulf/Release_notes.txt>
> —
> Tom
> _______________________________________________
> Dng mailing list
> Dng@???
> https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng