:: Re: [DNG] Can't get graphic output …
Top Page
Delete this message
Reply to this message
Author: Jarkko Lavinen
To: dng
Subject: Re: [DNG] Can't get graphic output from qemu
On Mon, Jul 13, 2020 at 01:00:36PM +0100, Mark Hindley wrote:
> I think the gui has moved to a separate package. Try installing qemu-system-gui.

Hello dng list

In the past I have used qemu with SDL on ascii. When I tried to
use it with gtk on beowulf, I get

qemu-system-x86_64 -display gtk
Failed to open module: /usr/lib/x86_64-linux-gnu/qemu/ui-gtk.so: undefined symbol: qkbd_state_lift_all_keys
qemu-system-x86_64: Display 'gtk' is not available.

The installed qemu* packages are;

  qemu                  1:3.1+dfsg-8+deb10u5 amd64
  qemu-system-common    1:3.1+dfsg-8         amd64
  qemu-system-data      1:5.0-6              all
  qemu-system-gui:amd64 1:5.0-6              amd64
  qemu-system-x86       1:3.1+dfsg-8         amd64
  qemu-utils            1:3.1+dfsg-8+deb10u5 amd64

I tried to downgrade qemu-system-gui to 1:3.1 but didn't help.

In ceres (schroot) using gtk works fine. When checking the
installed qemu* packages, all version numbers were 1:5.0-6.

Jarkko Lavinen