:: [devuan-dev] bug#828: marked as don…
Top Page
Delete this message
Reply to this message
Author: Devuan bug Tracking System
To: Mark Hindley
Subject: [devuan-dev] bug#828: marked as done (devuan-project: After an upgrade (apt update; apt full-upgrade) the PC fails to reboot correctly.)
Your message dated Wed, 20 Mar 2024 12:06:27 +0000
with message-id <ZfrRQxxXqQniNQ81@???>
and subject line Re: bug#812: Devuan project: merged-usr
has caused the Devuan bug report #812,
regarding devuan-project: After an upgrade (apt update; apt full-upgrade) the PC fails to reboot correctly.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@???

812: https://bugs.devuan.org/cgi/bugreport.cgi?bug=812
Devuan Bug Tracking System
Contact owner@??? with problems
Package: devuan-project
Severity: grave
Justification: renders package unusable

Dear Maintainer,

Yesterday I updated my OS in order to install AusweisApp2.
On the first attempt I got some errors from the update command, but they
seemed to be related to source packages. The second attempt appeared to
succeed, and AusweisApp2 worked as expected.

Today, after shutdown/reboot, there were lots of error messages. The switch to
high-resolution text display failed, no display manager started and I was dumped
into an 80x25 text screen, from which I could log in.

>From the error messages that flashed past, I was able to determine a few problems:

* One of the init scripts fails because it cannot find /sbin/modprobe.
** modprobe appears to be in /usr/sbin now.
** As a workaround, I created a symlink: ln -s /usr/bin/kmod /sbin/modprobe
* Similar failures for depmod and modinfo, similar symlinks created.

* After the above more error messages from /etc/init.d/mountall.sh, /etc/init.d/mountdevsubfs.sh and others
about not being able to find grep and sed. On examination, these files I noticed that the PATH is forced
to /sbin:/bin at the top. grep and sed are in /usr/bin now.
** As a workaround, I edited the files and added :/usr/sbin:/usr/bin to the path.

* After the above I got error messages about eudev. On examination of /etc/init.d/uedev I noticed a similar
problem with PATH, which I worked around in a similar way.

Now my PC boots to a display manager and I can log in as expected. I didn't notice any further error messages.

As you can see, the problems seem to be associated with several packages, so it's hard to pinpoint one package.

My guess is that the programs that I mentioned - modprobe, depmod, modinfo, grep, sed - and many others are
being installed in the wrong place. My reasoning is that, in a traditional Unix system, it should be possible
to place /usr in a separate filesystem that won't be available at the time these scripts are called.
However, on modern hardware, it's hardly ever necessary to have a separate filesystem for /usr, so it
could be simply a path problem in several init scripts of at least two packages (initscripts and eudev)

Best wishes,

-- System Information:
Distributor ID:    Devuan
Description:    Devuan GNU/Linux 6 (excalibur/ceres)
Release:    6
Codename:    excalibur ceres
Architecture: x86_64

Kernel: Linux 6.1.0-1-amd64 (SMP w/8 CPU threads; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled
Merged /usr is now enforced by base-files 13devuan4 and handled by debootstrap
1.0.134devuan2. Both of these versions are present in ceres and excalibur:

 base-files  | 13devuan4      | excalibur  | source, all
 base-files  | 13devuan4      | unstable   | source, all
 debootstrap | 1.0.134devuan2 | excalibur  | source, all
 debootstrap | 1.0.134devuan2 | unstable   | source, all

Golinux also posted an announcement[1] on the forum.

Therefore I am closing these reports as fixed.


[1]  https://dev1galaxy.org/viewtopic.php?id=6435