:: Re: [DNG] Daedalus install issue
Top Page
Delete this message
Reply to this message
Author: Tim Wallace
To: dng@lists.dyne.org
Subject: Re: [DNG] Daedalus install issue
Tried upgrading my third system, another System76 laptop, this one with an extra nvidia graphics card as well as the build-in intel, so two options there, and the annoying System76 switcher which I haven't been able to get working with devuan.  Chimaera was able to drive the external monitor port, though, which is done perhaps through nouveau.
Yup, same thing happened as with my desktop server.  Xorg died with an exception, so no GUI.  Tried doing a full install on another partition, and same deal there.  Had to go to the nvidia driver on this machine as well to get it working!  That laptop has some kind of "mobile 1650" nvidia chip.  Seems like nouveau is failing badly in the netinstall daedalus  method...
Not planning on buying any more system76 equipment though until they offer some non-systemd option.
On Monday, September 4, 2023 at 10:14:59 PM EDT, Tim Wallace via Dng <dng@???> wrote:

The netinstall put non-free-firmware in my apt sources.list.  Not sure if anything was installed from there during the installation.

    On Monday, September 4, 2023 at 09:46:21 PM EDT, Ralph Ronnquist <rrq@???> wrote:  

On Tue, Sep 05, 2023 at 01:27:07AM +0000, Tim Wallace via Dng wrote:
> I did an upgrade from chimaera on a system76 laptop and it went flawlessly.  It's a pretty generic install and I mostly use it when I travel.
> Today I tried to do my server/main desktop, ASR motherboard with i7-4790K, 32 GB ram and GeForce GTX 1660 graphics card.  There's a lot going on there, so I don't want to risk an upgrade.  I prefer to do a bare install so I have notes on everything I need to install anywhere.  I of course use a separate partition so I can boot both and take a few days or a week to upgrade different pieces like virtualbox.
> After doing the install, the system did not boot, which is common for me with this system.  I guess I should just tell it not to install grub.  My UEFI bios was able to be set to the right thing to boot and I got things straightened out.  However, I then did not get a graphical interface, just a console.  startx just silently failed.  The log showed a core dump due to illegal memory access and a backtrace which meant nothing to me; the nouveau driver was of course being used.  (I didn't immediately save the log and it seems to be overwritten now.)
> Rather than asking for help with nouveau, I added contrib and non-free to my apt sources from the console, and installed the Nvidia driver, which I ordinarily use anyway since nouveau cannot handle 60 fps 4K videos.  All is well now, but I thought I'd report this in case anyone else experiences it.  Nouveau used to work, just not fast.

As a hunch: for reasons that possibly can be explained, Debian added
the section "non-free-firmware" to their bookworm repo(s) and moved
the firmware packages previously in "non-free" into there. Devuan
daedalus of course inherited that. Possibly you had not prepared for
this particular novelty and if so that might explain your nouveau



> --Tim

> _______________________________________________
> Dng mailing list
> Dng@???
> https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng

Dng mailing list
Dng mailing list