:: Re: [DNG] Problem upgrading to Daed…
Top Page
Delete this message
Reply to this message
Author: Marc Shapiro
To: dng
Old-Topics: [DNG] Problem upgrading to Daedalus
Subject: Re: [DNG] Problem upgrading to Daedalus (SOLVED)

On 8/20/23 20:49, Marc Shapiro wrote:
> I am currently running Chimaera and wish to upgrade to Daedalus.
> While I know that it should be perfectly safe to change the lines in
> my sources.list from Chimaera to Daedalus, then run apt update, apt
> upgrade and apt dist-upgrade, I also know that sometimes this does not
> go well.  I was a Debian user, up until Buster.  When I couldn't get
> Buster to work without systemd I said it was time to switch.  I have
> been using Devuan ever since.  There were times when an upgrade did
> not go as smoothly as it should have.
> That being the case, when a new release comes out, I copy the entire
> system to a new set of partitions, get that booting, and then upgrade
> the copy.  That way, I still have the previous release still bootable
> in case something goes wrong.
> I have modified /etc/fstab in the copy, and modified and run lilo from
> the original Chimaera.  When I try to boot to the copy of Chimarea,
> however, I get a kernel panic when it tries to mount /usr.  It says
> the file can not be found.  This sounds to me like /dev is not
> populating.  On my current Chimaera system, /dev, /sys, /proc, and a
> few others have filesystems mounted on them without needing anything
> in /etc/fstab:

Used dd to copy the LVs instead of rsync and it worked like a charm! 
Easier, too.

Modified /etc/fstab, reran lilo and booted right into the copy of Chimaera.

Modified /etc/apt/sources.list.

   apt update
   apt update
   apt full-upgrade

Running on Daedalus, now.