:: Re: [DNG] New to Devuan - install p…
Top Page
Delete this message
Reply to this message
Author: Bill Purvis
To: Lorenz
CC: dng
Subject: Re: [DNG] New to Devuan - install problem
Hi Lorenz,
On 19/04/2023 14:36, you wrote:
> Hi,
> Il giorno mar 18 apr 2023 alle ore 17:28 Bill Purvis <bill@???>
> ha scritto:
>     ... When it rebooted it just comes up wit a grub prompt.

>     It's been many years since I had to use grub in this way. Should
>     it not simply boot up the
>     installed system?

> It should be a Grub menu that allow to choose between different OS or
> kernel (if you have more than one installed), and it
> should automatically boot the default option after a few seconds timeout.
> Assuming with 'grub prompt' you mean the command line provided by
> Grub, yes, something went wrong.
> Do you choose a GPT or MBR layout? installing grub for GPT in MBR or
> vice versa may cause this; there is also a bad bug that
> is hitting stable systems (at least in Debian) this way, but you
> should read a 'symbol error' or something before the prompt
> Anyway, since you get the prompt, I suggest to try to boot from there
> and then reinstall Grub.
> example:
> >ls  (should give a list of disks, like hd0 hd1 and partition, like
> (hd0,msdos1)
> try to find out which partition is the devuan root, for example
> >ls (hd0,msdos1)/      (try each partition untill you get a list of
> root subdirectories)
> then do (assuming hd0,msdos1 is your root)
> >set root=(hd0,msdos1)
> >linux /boot/vmlinuz-[ full name of the image,use TAB for
> autocompletion ]  root=/dev/sda1
> >initrd /boot/initrd.img-[use TAB, same version as the vmlinuz]
> >boot
> I can't give you exact comands since I don't know your disks layout
> and names of installed kernels
> Lorenzo

Thanks, but I've managed to sort it out. I had booted the memory stick
in non-UEFI mode, then tried
to set it up as a UEFI system, Not being well up on booting with grub
these days, I couldn't remember
how to do that and a couple of trials just produced more errors.

I've now done a complete reinstall booting the install disk in UEFI mode
and it all worked perfectly.



| Bill Purvis                            |
| email:bill@???                   |