:: Re: [DNG] daedelus package dependen…
Top Page
Delete this message
Reply to this message
Author: aitor
To: dng
New-Topics: Re: [DNG] daedelus package dependency issue - SOLVED by update/upgrade
Subject: Re: [DNG] daedelus package dependency issue

On 30/10/22 22:58, Joel Roth via Dng wrote:

> Dear colleagues,
> I got myself into some trouble by upgrading
> to daedelus, which is not a stable distribution.
> When I went to install openvpn, I got this error message:
> The following packages have unmet dependencies:
> libc6-dev : Breaks: libglib2.0-dev (<= 2.72.3-1) but 2.66.8-1 is to be installed
> E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
> I did apt-get update/upgrade before trying this.
> Also apt-mark showhold didn't list any packages as held.
> Do you have any suggestions or references?

Perhaps you have some package depending on libglib2.0-dev (=2.66.8-1). There are several
ways to list dependent packages, i.e. reverse dependencies. But what you need is a way to
determine the packages that depend on a certain version of a dependency.
Try with this:

$ aptitude -v --show-summary=all-packages-with-dep-versions why <package_name>

In my system:

~$ aptitude -v --show-summary=all-packages-with-dep-versions why libglib2.0-dev
Paquetes que dependen de libglib2.0-dev:
  libgtk-3-dev D: libglib2.0-dev (>= 2.57.2)
  librsvg2-dev D: libglib2.0-dev (>= 2.50.0)
  libvte-2.91-dev D: libglib2.0-dev (>= 2.40.0)
  libwnck-3-dev D: libglib2.0-dev (>= 2.32)
  libxfce4panel-2.0-dev D: libglib2.0-dev
  libxfce4ui-2-dev D: libxfconf-0-dev D: libglib2.0-dev
  libxklavier-dev D: libglib2.0-dev (>= 2.16.0)