:: [DNG] gdb won't run
Top Page
Delete this message
Reply to this message
Author: Alessandro Vesely
To: [DNG]
Subject: [DNG] gdb won't run
Hi all,

don't know since when this happened, maybe since I upgraded to Chimaera.

When I run gdb I get:

src$ gdb -n -q --args ./anyexec
Reading symbols from ./anyexec...
(gdb) break main
Breakpoint 1 at 0x7c7a: file anyexec.c, line 10.
(gdb) run
Starting program: /home/ale/tmp/src/anyexec
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

Breakpoint 1, main (argc=3, argv=0x7fffffffe1c8) at anyexec.c:10
gdb: symbol lookup error: gdb: undefined symbol: _ZN9srchilite15SourceHighlightC1ERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE
src$ echo $?

Demangled symbol seems to be:
srchilite::SourceHighlight::SourceHighlight(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)

I cannot strace gdb, so I don't know where it looks for that missing symbol.

I tried to remove and reinstall gdb, reinstall all libsource-highlight*, to no avail.

Any idea?