:: Re: [DNG] pkexec in Chimaera
Top Page
Delete this message
Reply to this message
Author: tempforever
To: dng
Subject: Re: [DNG] pkexec in Chimaera
Thanks for the (attempted) help.
su -c - root mousepad returned the same error (Mousepad-CRITICAL...
Failed to initialize xfconf: The connection is closed)
su -c - root xterm
and then mousepad (in that xterm) returned the same error again.

I noticed on my Beowulf system I get a similar "error" except it says
dconf-WARNING ... failed to commit changes to dconf: The connection is
However, mousepad actually opens there, I guess because it is a warning
instead of a critical error in Beowulf?

I'm not terribly concerned about (not) being able to run GUI programs as
root, it just seemed odd to me that pkexec would require a different
user's password, especially when specifying --user root.

Steve Litt wrote:
> Try this:
> su -c - root mousepad
> Remember to put the dash between -c and root.
> If you get the same results, perform the following:
> su -c - root xterm
> Now, within that xterm, run the mousepad command and see what goes
> wrong. It's probably a wrong directory, or perhaps some missing
> environment variable, either of which can be cured by a shellscript.

Thank you for the help also.  sudoedit requires user "a" to be in sudo
group, which I'd prefer not to do.  A non-gui text editor invoked with
su -c will work for now.

Lars Noodén via Dng wrote:
> You could consider running sudoedit instead.  That will allow you to
> edit a file as root (or any other designated account) while still
> running the editor itself under the unprivileged account.  One should
> not run graphical programs as root, if it can be avoided.