:: Re: [DNG] Beowulf installation skip…
Top Page
Delete this message
Reply to this message
Author: Patrick Bartek
To: dng
Subject: Re: [DNG] Beowulf installation skipped networking. Quickest fix? SOLVED
On Sat, 27 Mar 2021 17:28:37 +1030
dvalin@??? wrote:

> On 26.03.21 06:54, Patrick Bartek wrote:
> > On Fri, 26 Mar 2021 15:49:13 +1030
> > dvalin@??? wrote:
> >
> > >  My shiny new Beowulf  3.0.0 install on an Intel NUC skipped
> ethernet
> > > stuff, perhaps because the ethernet cable wasn't inserted at the
> time?
> > >
> > > Now, I can start hacking /etc/network/interfaces, /etc/hosts,
> > > resolv.conf,
> > > etc., but will that reveal so much missing that I'm better off
> doing
> > > another
> > > install with the LAN plugged in? Heck, are there kernel modules
> > > missing?
> >
> > Have your tried juat rebooting with the ethernet cable plugged
> > in?
> I probably should have, but on finding no mention of eth0 in the /etc
> files, I reinstalled Beowulf with the cable plugged in. It was so
> quick
> compared to the old days, that am dazed that it's all there. Then
> networking just worked ... even though there was still no mention of
> eth0.

Some systems have weird designation for the ethernet port. Mine is

> I hadn't been asked for an ethernet address or subnet mask - it was
> all
> magic.

Linux has gotten smarter. It can now set all that up without user

> I've only had Beowulf for a few hours, but it is immediately
> comfortable.

I'd been using Debian for years (since Sarge), but when they switched
to systemd from sysvinit, I started looking for an alternative.
Luckily, Devuan Beowulf came along and I abandoned Debian. Happy with
it. All working well. And I have a customized system: no desktop,
just a window manager, a single panel, etc.

> Whoever thought of leaving the release notes on the desktop deserves a
> medal. That was the first thing I was going to hunt for, as I'd read
> the
> note on pulseaudio prior to install. The problem line is commented
> out,
> but I still have no audio; will have to poke at that a bit. But first
> to
> move email to the new host, so I can get off this webmail horror.

All I did to enable sound was to use alsamixer to turn on the master
volume. Volumes for all sound channels is zero by default.