:: Re: [DNG] Trouble booting Beowulf o…
Top Page
Delete this message
Reply to this message
Author: dvalin
To: dng
Subject: Re: [DNG] Trouble booting Beowulf on an Intel NUC8i5BEK : SOLVED

Being stuck on a horrible webmail thing until the new host is up,
limit the number of posts lacking In-Reply-To for proper MUA
by replying to Marjorie, Steve, and Florian here, shortest first.

TL;DR: Punchline at the end.

On 25.03.21 14:28, Florian Zieboll via Dng wrote:
> On Thu, 25 Mar 2021 17:30:14 +1030 dvalin@??? wrote:
> >  Have just taken delivery of an Intel NUC8i5BEK, installed RAM &

> > A USB stick with:
> > $ dd if=~/Downloads/devuan_beowulf_3.0.0_i386_desktop-live.iso
> > of=/dev/sdb  bs=512k
> > looks good mounted on another host, but doesn't boot in the NUC.
> Does the "other host" recognize it as bootable in UEFI mode? Did you
> check for a BIOS update? Did you try with "Secure Boot" disabled?

Ah, have now tried with "Secure Boot" disabled. No change.
And it doesn't boot the laptop, either.

I'll give a unetbootin version a go. (As dd had worked with the Udoo
I'd become complacent.) See below.

On 25.03.21 07:21, Steve Litt wrote:
> My experience, over many years with many distros, is that "bootable
> thumb drives" aren't so bootable. Some work with a dd transfer but
> don't work with unetbootin. Others work with unetbootin but not dd
> Others require all sorts of special sauce to get them bootable. You
> mentioned that your thumb drive "looks good" on another host. Unless
> "looks good" means the other host booted off it, the thumb drive's
> bootability is still up in the air, and when combined with

> boot order, and all sorts of other stuff, the last thing you need is

> boot media you can't trust.

Yeah, the first time around that special sauce gets up my nose -
probably from not holding my mouth right.

Rats, the unetbootin version of Beowulf also didn't boot in either the
NUC or the laptop.

> I'd purchase a $35.00 USB DVD burner
> drive, burn a bootable CD or DVD, then boot off of that

I'm sorely tempted, though it isn't here now, so I'll persist a little
more, as that's usually what it takes. (Achieved occupancy permit for
rural off-grid owner-build on Monday, after 2.5 years of effort,
self-drawn plans getting planning and building approval, and digging 7

of trench by hand during a Covid lockdown, so am in a persistent

On 25.03.21 10:57, Marjorie Roome via Dng wrote:
> Hi Erik,
> I have an older, more basic NUC running in legacy mode as my email
> server, however I think you have the newer AptioV bios.
> Check here, where you can see the two possible BIOS start pages:


It turns out that my NUC also has the Visual BIOS. It was pretty easy
navigate after the first time through, with more than one path to the
"Advanced" boot stuff.


> I think you need the investigate the 'Boot' tab first.

Yes, and I'd love to try legacy mode, but that just tells me
"No Boot Drive" when I select it in the Boot Order window's legacy

Oh Farnarkle! Do you know what the secret sauce is?

Ignore the "No Boot Drive" report when enabling Legacy Boot.
Disable UEFI Boot.
Persist in pressing F10 to save the config, despite the BIOS ignoring
the first three presses, and hanging for ten seconds or so.

Mind you, my euphoria was somewhat dimmed by the fact that the long
scroll of linux boot messages ended in a uniformly light grey screen
devoid of any content, textual or graphical. However, ditching the
unetbootin stick and returning to the dd version, all is good. It
boots all
the way to the Devuan desktop.

Now I just have to get the battery corrosion off the neglected
mouse, so I can do clicky stuff. (Taking time out for long projects
have consequences.)

Many thanks folks, for helping me find the special sauce on this one.
A BIOS like that does tend to keep Linux within a motivated community,
I figure.

(Rather pleased with progress so far. :)