:: [DNG] (Almost) no sound under Beow…
Top Page
Delete this message
Reply to this message
Author: Marc Shapiro
To: dng
Old-Topics: Re: [DNG] (Almost) no sound under Beowulf
Subject: [DNG] (Almost) no sound under Beowulf (SOLVED)
Oops!  I forgot to add (SOLVED) to my last subject line.

-------- Forwarded Message --------
Subject:     Re: [DNG] (Almost) no sound under Beowulf
Date:     Sun, 27 Sep 2020 09:34:33 -0700
From:     Marc Shapiro <marcnshap@???>
To:     dng@???

On 9/26/20 6:55 PM, Gregory Nowak wrote:
> On Fri, Sep 25, 2020 at 10:54:14PM -0700, Marc Shapiro via Dng wrote:
>> The issue that I am having is with sound.  My daughter reported that
>> it was
>> not working.  I tried playing a video (in Firefox) from my login and also
>> got no sound.
> You've already gotten good suggestions in this thread. I'd concur with
> the advice to get rid of pulseaudio, and use ALSA. If a particular
> application requires pulseaudio, install the apulse package, and start
> that application through apulse.
> One thing I haven't seen mentioned so far is to make sure that each
> user who is supposed to be able to play sound is a member of the audio
> group. If they aren't in the audio group, add them to the audio group,
> log them out, and log them back in. Note, I get sound in Beowulf in
> firefox just fine with out pulseaudio installed.
>> 3) The 'play' utility from the sox package gives an error whenever I
>> try to
>> play an mp3 file.  Using 'aplay' to play .wav files works fine.  What
>> do I
>> need to do to play mp3s from the commandline?
> Do you have the libsox-fmt-mp3 package installed? Better yet, unless
> you have some reason not to, just install the libsox-fmt-all
> package. For playing music from the command line, I use mplayer. As
> you've discovered, aplay works too, and play should work as well once
> you install the necessary format support.
> Greg

I do run Firefox, which is why I have pulseaudio installed.  When pulse
is running, I have had no issues with it.  The problem was that, for
whatever reason, pulse was not starting for all users when they logged
in.  I added a line to start it in each .bashrc and that problem was
solved.  The problem with mp3s from the commandline was the lack of
libsox-fmt-mp3.  I installed libsox-fmt-all and that issue is solved, as

Thank you, everyone, for your help.  I think that this installation is
ready to leave running and see if my wife and daughter have any issues
with it.