:: [DNG] Tried Debian Stretch with sys…
Top Page
Delete this message
Reply to this message
Author: Edward Bartolo
To: dng
Subject: [DNG] Tried Debian Stretch with systemd out of constrainsts
These last few days I tried Debian Stretch with systemd on a piece of
'old' hardware. I used Stretch to allow snapd and then openhantek to
be installed.

The following is my experience: I do not intend to negatively
criticise systemd just for the sake of it. I would like to recount my
experience, which is the experience of someone, who had to try systemd
out of constraints, but was set back for various reasons.

During boot Stretch faltered several times. The first falter was,
trying to resume from swap. This wasted about one minute of boot time.
The second was udev complaining pcspkr was already detected or
something like that. Then udev faltered at least twice wasting more
than 90 seconds. The reason was Broadcomm wifi driver not being
successfully loaded. As if these grave hiccups were not enough, there
was yet another delay when the boot 'MTA' line was displayed.

After this long unnecessary wait and rising exaspiration, the login
manager screen appeared. When the desktop, xfce4, was displayed I was
yet another time dismayed to notice the time lag graphics were being
rendered and I remembered someone on this mailing list discussed
Debian's decision to use the main CPU as a graphics renderer when a
proper powerful GPU is apsent. Needless to state this was a blow under
the belt for me: I could not use a computer with so much sluggishness.
This made me think about those who cannot afford to frequently replace
their computers and yet they are being constrained to replace their
old hardware, because newer software expects to use a proper GPU, and
this under Linux!

So, I decided to remove systemd and point to Devuan's ASCII
repository. I did the usual dist-upgrade command with Debian's
repository still included in /etc/apt/sources.list. Then, I installed
sysvinit and removed systemd. At the end, I removed the link to
Debian's repository and only used Devuan's. When I booted the system,
there was an initial delay caused by the swap partition's UUID being
mismatched. Udev continued to misbehave and waste boot time, pcspkr
also caused another delay, dhclient yet another delay and finally, the
MTA line, whatever that may be.

These problems were corrected by making sure to reinstall the kernel,
udev and the Broadcomm firmware. I also made sure the right UUID for
swap is used.

Now, the OS boots nicely without systemd which is supposed to surpass
sysvinit regarding boot speed.

I still have yet not figured out how to avoid having to use snapd and
install the firmware for the oscilloscope, Hantek 6000B (USB). I have
successfully extracted .hex files from the MS Windows drivers but have
no idea what to do with these hex files which are supposed to contain
the oscilloscope's firmware. The openhantek package has a .rules udev
file to enable detection of the oscilloscope. However, the kernel
still wants to know where to look for the oscilloscope's firmware, and
that particular information is missing.