:: [DNG] SOLVED Re: Upgraded to Beowu…
Top Page
Delete this message
Reply to this message
Author: Alessandro Selli
To: dng
Old-Topics: Re: [DNG] Upgraded to Beowulf, GIMP is broken
New-Topics: Re: [DNG] *** GMX Spamverdacht *** SOLVED Re: Upgraded to Beowulf, GIMP is broken
Subject: [DNG] SOLVED Re: Upgraded to Beowulf, GIMP is broken
On 03/02/19 at 15:28, Alessandro Selli wrote:

> On 03/02/19 at 15:09, Alessandro Selli wrote:
>> On 03/02/19 at 14:59, Dr. Nikolaus Klepp wrote:
>>> Anno domini 2019 Sun, 3 Feb 14:53:30 +0100
>>> Alessandro Selli scripsit:
>>>> On 02/02/19 at 21:43, Harald Arnesen via Dng wrote:
>>>> [...]
>>>>   I took away the deb-multimedia repository *before* the upgrade, left
>>>> the Videolan one and DVD playing works fine.
>>>>   Gimp does not, however:
>>>> gimp: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgegl-0.4.so.0:
>>>> undefined symbol: babl_format_with_space
>>>> dpkg-query --search /usr/lib/x86_64-linux-gnu/libgegl-0.4.so.0.412.0
>>>> libgegl-0.4-0:amd64: /usr/lib/x86_64-linux-gnu/libgegl-0.4.so.0.412.0
>>>> apt-cache policy libgegl-0.4-0
>>>> libgegl-0.4-0:
>>>>   Installed: 0.4.12-2
>>>>   Candidate: 0.4.12-2
>>>>   Version table:
>>>>  *** 0.4.12-2 500
>>>>         500 https://pkgmaster.devuan.org/merged beowulf/main amd64 Packages
>>>>         100 /var/lib/dpkg/status
>>> I had to uninstall gimp, purge all packages from dmo, purge all left behind configs and then reinstall gimp.
>>   The only deb-multimedia package left is deb-multimedia-keyring, which
>> adds the file /etc/apt/trusted.gpg.d/deb-multimedia-keyring.gpg to the
>> filesystem.
>>   I'll try purging gimp and libgegl-0.4-0, reinstall them and see if
>> that's enough.
>   No luck.  The issue affect xsane too.
>   I purged gimp, xsane and libgegl-0.4-0, reinstalled gimp xsane and
> still get the same error.
>   I have no packages from deb-multimedia or backports or experimental,
> which were are removed before the upgrade.

  All right, this is the right way to proceed:

apt-get purge gimp libgegl\* libgimp2.0 libbabl\* xsane && apt-get clean
&& apt-get -y install gimp xsane

  Now both xsane and gimp work.

  Next issue, firefox has lost his voice.  But only when run from XFCE's
panel, not when run as apulse firefox from the command line.

Alessandro Selli <alessandroselli@???>
VOIP SIP: dhatarattha@???
Chiave firma e cifratura PGP/GPG signing and encoding key: