:: Re: [DNG] Bash keyboard shortcuts w…
Top Page
Delete this message
Reply to this message
Author: Miroslav Rovis
To: Alessandro Selli
CC: dng
Subject: Re: [DNG] Bash keyboard shortcuts working really ugly [SOLVED]
On 170526-14:52+0200, Alessandro Selli wrote:
> On Thu, 25 May 2017 at 07:30:29 +0000
> Miroslav Rovis <miro.rovis@???> wrote:
> > On 170525-06:51+0200, Alessandro Selli wrote:
> > > On Wed, 24 May 2017 at 16:27:36 +0000 Miroslav Rovis
> > > <miro.rovis@???> wrote:
> > >

[NOTE: ... typos in the old quoted texts below edited for readability
('s/demonstate/demonstrate/' in two pastes of mine, also 's/undr/under/' in
Alessandro's reply) ]

The Issue
> > > > mr@gd0v:~$ I am only trying to demonstrate the issue.
> > > >
> > > > That's ' I' in first editable space of the command line. I move to
> > > > beginning with Ctrl-A.
> > > >
> > > > And I press Alt-D. Here's what I get:
> > > >
> > > > mr@gd0v:~$ ä I am only trying to demonstrate the issue.
> > > >
> > > > But I did press Alt-D... So that one doesn't work.
> > ...

Alessandro's reply which solved it for me:

> > > This is a problem with Xresources if it happens under Xorg, and/or with
> > > input library keybindings, that is with the .inputrc file.
> > >

[NOTE: Let's make the solution conspicuously stand out, for people who will be
getting here via search engines with the problem like mine: ]

> > > Under X I can replicate your problem when I comment this line in
> > > ~/.Xresources:
> > >
> > > *metaSendsEscape: true


^ ^ ^ ^ ^ ^ ^ ^ ^ ^ ^ ^ ^ ^ ^
| | | | | | | | | | | | | | |

> > >
> > > Try uncommenting or adding this line, then run:
> > >
> > > xrdb -merge ~/.Xresources
> > >
> > > open a new terminal and see if the problem went away.
> >
> > #======================================================================#
> > #      And it did go away! Both Alt-D and Alt-Backspace now work!      # 
> > #======================================================================#


That's all. Now follows my belated reply to Alessandro's kind email. It is
belated because I hadn't secured sufficiently well my Devuan to be able to use
it more freely until a few hours ago.

Being it very likely a fact that my Gentoo has been broken into[1] again
(mildly so, but yes: broken into, IMO), notwithstanding and regardless of my
serious and stubborn effort to not be owned again[2]), I decided to take
security even more seriously[3] with my main OS of the next months to come,

Because I want my Devuan to endure any hardship and to last for me, and that I
be able to do good things with it :) .

Alessandro pls. accept my apologies for being this late. In truth I got
hundreds of emails (from all kinds of GNU/FOSS/... lists that I'm subscribed
to) today with remarkably (so far) well working Getmail, Maildrop and Mutt, as
well as Postfix --for sending only--, along with for local mail... Hundreds of
emails because since my reply to Steve which I sent just some twenty minutes
after I replied to you, I haven't gone online with my Devuan, since four days
ago, until today. I really want to make my Devuan secure.

> /me pops open a bottle of Spumante and toast!

My toast to you too, but the red Italian wine you mention further below sounds
even more delicious!

> > And just think of it: I was willing (almost ready) to reinstall my Devuan
> > because of this trivial glitch, kind of... Phew!
> It's trivial *after* you learned what the issue was, but it can drive you
> crazy for weeks before that! Especially when the issue concerns some of
> those arcane, scantly documented old-time Unix config files and settings very
> few people think of when something misbehaves under X.
> I am not sure this setting, that is, everything you put in your
> ~/.Xresources file, is read automatically at every X session, though I
> believe it probably is: it depends by your Desktop Manager. In my Devuan
> system I find it configures in /etc/X11/Xsession, where I can find:

(Looking into):

> #!/bin/sh
> #
> # /etc/X11/Xsession
> #
> # global Xsession file -- used by display managers and xinit (startx)
> [...]
> and then in /etc/X11/Xsession.d/30x11-common_xresources:
> # $Id: 30x11-common_xresources 305 2005-07-03 18:51:43Z dnusinow $
> # This file is sourced by Xsession(5), not executed.
> [...]
> if has_option allow-user-resources && [ -f "$USRRESOURCES" ]; then
>   if type xrdb >/dev/null 2>&1; then
>     xrdb -merge $USRRESOURCES
>   else

I found both the files, and they, by quick check, have the same content you
cite in my box as well, but I only vaguely understand what they do...

> [...]
> > But that's what the developers are here for us users/hopeful testers...
> Surely!
> By the way, people: as I was perusing among the files in /etc/X11
> documenting this email of mine, I updated this file:
> --- /etc/X11/wdm/Xresources     2017-05-26 14:12:25.104413649 +0200
> +++ /etc/X11/wdm/Xresources.orig        2017-05-26 14:22:20.487768651 +0200
> @@ -8,8 +8,7 @@
>         Ctrl<Key>Return: set-session-argument(failsafe) finish-field()\n\
>         <Key>Return: set-session-argument() finish-field()
>  xlogin*borderWidth: 3
> -!xlogin*greeting: Debian GNU/Linux (CLIENTHOST)
> -xlogin*greeting: Devuan GNU/Linux (CLIENTHOST)
> +xlogin*greeting: Debian GNU/Linux (CLIENTHOST)
>  xlogin*namePrompt: login:
>  xlogin*fail: Login incorrect
>  #ifdef COLOR

(I know you wrote that for others as well,) I have a similar issue, now that I
got close to using my uncenz set of scripts ( https://github.com/miroR/uncenz )
in Devuan, after having installed Devuan Jessie RC2 some, what 10 or more days
ago, yesterday having updated/upgraded it with Debian Stretch, because I really
needed the FFmpeg --available strong and fully in Stretch, not in Jessie-- ...

I have a similar issue to the issue that you corrected in
/etc/X11/wdm/Xresources (which I don't have, since I have a mean sans-dbus
system; I also got rid of pulseaudio, pure alsa seems to work fine in my box).
Namely, after my update/upgrade with Stretch, now my tty reads like this:

Debian GNU/Linux 9 gd0v tty5

gd0v login:

( I did look up Jenkins, but I remained on the surface at it... and lots more
while I was searching for solutions to solve issues in my Devuan...
I hope some day I'll be able to contribute to Devuan project.. )

> And then I figured out where WDM get's its Debian login screen logo:
> [root@devuan02 ~]# grep -B1 -A2 Debian /etc/X11/wdm/wdm-config.orig
> ! DisplayManager*wdmLogo:       /usr/share/pixmaps/gnuLogo.xpm
> DisplayManager*wdmLogo:         /usr/share/pixmaps/wdmDebianSwirl.xpm
> ! DisplayManager*wdmReboot:       /sbin/reboot
> ! DisplayManager*wdmHalt:         /sbin/halt
> [root@devuan02 ~]#

> But I cound not find a Devuan logo in /usr/share/pixmaps/ ! :-(
> I then run:
> convert /usr/share/reportbug/devuan-emblem.svg -resize
> 200x130 /usr/share/pixmaps/wdmdevuan-emblem.xpm
> and updated /etc/X11/wdm/wdm-config like this:
> --- /etc/X11/wdm/wdm-config     2017-05-26 14:31:33.751122119 +0200
> +++ /etc/X11/wdm/wdm-config.orig        2017-05-26 14:21:29.457766794 +0200
> @@ -32,7 +32,7 @@
>  DisplayManager*wdmLogin:        /usr/bin/wdmLogin
>  DisplayManager*wdmBg:           solid:Gray85
>  ! DisplayManager*wdmLogo:       /usr/share/pixmaps/gnuLogo.xpm
> -DisplayManager*wdmLogo:                /usr/share/pixmaps/wdmdevuan-emblem.xpm
> +DisplayManager*wdmLogo:                /usr/share/pixmaps/wdmDebianSwirl.xpm
>  ! DisplayManager*wdmReboot:       /sbin/reboot
>  ! DisplayManager*wdmHalt:         /sbin/halt
>  DisplayManager*wdmReboot:       /usr/bin/sudo /sbin/shutdown -r now

> Of course, I'd loove to see this as the default WDM settings in Devuan! :-)
> > But
> > we wouldn't even have Devuan if it weren't for bright people like you devs!
> I agree, my kudos to Devuans' devs and admins!

But you too are at least a contributor, Alessandro, aren't you? To be able to
find a solution to my query, by previous understanding of these matters, which
you did... You must be at least a power user, and a capable one! I thought you
were a developer! It wasn't a simple query, that one...

Let me translate the (further) below to the lingua franca of today, which is
English (and, for the less learned among the readers: 'lingua franca' are Latin
words that approximately mean: free language, such as in free trade, or free
communication, the stress in the meaning being in the freedom from accuracy in
the use of such language :) ):

> E un bicchiere di rosso a te, caro vicino di casa! :-)

"A glass of red wine to you, dear neighbor ... (from a neighboring country)!
Because Alessandro meant to say 'vicino di paese', not 'vicino di casa' (the
latter really translates as neighbor because living in a nearby house, 'casa'
means 'house').

Molto grazie per il buon vino rosso dalla Bell'Italia!
( Many thanks for the good red wine from the Beautiful Italy!)

> --
> Alessandro Selli http://alessandro.route-add.net
> VOIP SIP: dhatarattha@???
> Chiavi PGP/GPG keys: B7FD89FD, 4A904FD9

Most kind greetings to you, my vicino di paese!


I am transitioning from my Gentoo system that has somehow been broken
into, even though probably very limitedly so, and I don't have links so easily
available in my Devuan.

I have, for years now, nurished fervently the ambition to control all
interactions with my system when I go online, and that, at the current level of
my ability to capture, decrypt, and filter and examine the network, means not
much going online till I fully deploy my *uncenz* (mentioned, and link given,
further above)...

So, in case some of the links below won't be correct (or complete), allow
ERRATA in some later email.


Strange script planted with Bash

System attacked, Konqueror went on window-popping spree!

[3] The methods that I use, and without which I wouldn't last online for a
    fraction of time that I do, are Air-Gap installing and cloning, as can be
    read in:
Air-Gapped Gentoo Install, Tentative

Postfix smtp/TLS, Bkp/Cloning Mthd, Censorship/Intrusion

( I wish/hope to be able to write a Devuan howto on these methods, a hands on
howto for Devuan users... Pls. notice the 'wish/hope' expression that I used...
I'm in a lot of work, and, beside other things in life, but only staying with
Devuan, there are other things to ask on Devuan dev1galaxy.org Forums before
that... Alas, also my slowliness in doing things is such that I sometimes worry
about getting to do them at all... )

Miroslav Rovis
Zagreb, Croatia