:: Re: [DNG] chroot sees wrong version…
Top Page
Delete this message
Reply to this message
Author: Rainer Weikusat
To: dng
Subject: Re: [DNG] chroot sees wrong version of libc
Didier Kryn <kryn@???> writes:
> Le 28/04/2016 15:34, Rainer Weikusat a écrit :
>> Didier Kryn <kryn@???> writes:
>>> Le 27/04/2016 23:29, Haines Brown a écrit :
>>>> I found I had to bind mount /sys before I could install grub2.
>>>      A few tricks:

>>>      It is most of the times necessary to bind-mount /proc and /sys
>>> when working in a chroot. Depending what you do, /dev may also be
>>> necessary. Also copy /etc/hosts and /etc/resolv.conf when working with
>>> network.

>>>      Happy that it worked :-)
>> debootstrap still doesn't install the wheezy i686 libraries in the
>> chrooted environment.

>     He's talking of installing grub2...

And I was replying to you, specifically, to the "Happy that it worked"
which ought to refer to the "That was the answer!" in the original
posting. But it wasn't "the answer" as manually running debootstrap in
two steps on the same system doesn't do anything the single-step
debootstrap wouldn't also do on its own and the library problem can't have
been created by debootstrap.

As far as I can tell (and I did a couple of test installs), the stock
debootstrap procedure works fine for creating a Devuan jessie on a Debian
wheezy host.