:: Re: [FreeJ] Blank screen when tryin…
Top Page
Delete this message
Reply to this message
Author: Pablo Baena
Date:  
To: freej
Subject: Re: [FreeJ] Blank screen when trying to capture from webcam
Hi, I tried building the debian package on ubuntu, but there's a
dependency I can't satisfy because libmozjs-dev conflicts with
xulrunner-dev on ubuntu.

So I tried compiling from source, but I got the same dependency problems.

I guess I should wait till ubuntu fixes this problem, in the meantime
I'll just use dynebolic to make some tests.

On Mon, Nov 9, 2009 at 9:00 AM, <freej-request@???> wrote:

> Message: 1
> Date: Mon, 9 Nov 2009 05:39:11 -0300
> From: Pablo Baena <pbaena@???>
> Subject: [FreeJ] Blank screen when trying to capture from webcam
> To: freej@???
> Message-ID:
>        <36be2c7a0911090039k103e9c2xd341b9bc498f8c08@???>
> Content-Type: text/plain; charset=ISO-8859-1
>
> I was able to finally compile and install  freej-0.10git20081231 on
> Ubuntu, but when executing: "freej /dev/video0"  the freej preview
> screen is just black. I pressed all the keys, tried adding effects,
> whatever, can't make it work.
> No error messages, just a black screen. I
>
> I tried using libv4l ld preloads, no luck anyway, just the blank screen.
>
> I saw that there are javascript scripts to stream to icecast, but
> first I just want to verify that capturing works, before configuring
> icecast.
>
> Thanks in advance.
>
>
> ------------------------------
>
> Message: 2
> Date: Mon, 9 Nov 2009 10:58:52 +0100
> From: Luca Bigliardi <shammash@???>
> Subject: Re: [FreeJ] Blank screen when trying to capture from webcam
> To: FreeJ mailinglist <freej@???>
> Message-ID: <20091109095852.GM18218@???>
> Content-Type: text/plain; charset=us-ascii
>
> On Mon, Nov 09, 2009 at 05:39 AM, Pablo Baena wrote:
>
> Hi Pablo,
>
>> I was able to finally compile and install  freej-0.10git20081231 on
>> Ubuntu, but when executing: "freej /dev/video0"  the freej preview
>> screen is just black. I pressed all the keys, tried adding effects,
>> whatever, can't make it work.
>> No error messages, just a black screen. I
>>
>> I tried using libv4l ld preloads, no luck anyway, just the blank screen.
>
> It seems you're hitting the unicap libraries problem, can you try other
> unicap-based applications to confirm?
> We didn't get any reply from unicap author when we asked about this bug so
> we've started an experimental cam layer based on opencv, but you'll need
> latest git for that (if you're using deb-src from debian you can try
> 0.10git20090824-1+b1). If you're on a 64bit machine you might get this bug
> while compiling: http://bugs.debian.org/543546
>
> To start the experimental layer just use:
>
> freej layer_opencv_cam
>
>
>
> Luca
>
> --
> Beware of programmers who carry screwdrivers.
>                        -- Leonard Brandwein